ForumsSoftware ← Virta no sound when reopen the project.version 1.02.

when I reopen the project in live,virta can not shows input sigal,but no frequency,then it will no sound in other preset too.only way is reload virta.

Win7 64bit,ableton live 9.6.virta 1.02.
need helo,thanks.

Sorry you're having trouble. I first heard about something like this (Virta audio locking up) last week. I'll try to sort this out and update ASAP.

If you have time, can you please try this Virta 1.1 DEMO for Windows and let me know if it fixes things? This could help me track down how the problem started.

Can you tell me what buffer size you are using in Live? I have heard of problems with larger buffers, over 1024. If you are using a big buffer you can try reducing it.

thanks for your so quick reply Randy~
I said wrong,sorry.when I reopen prejet,virta no sound,but when I change preset,it will sounds,and then I change it back to the preset which I need,it's work.but when I open the project next time,it no sound agian.
I am run virta on buffer 128.and other buffer is the same.
other problem is :
I install the exe that you give me.virta still shows 1.02 and registed to me. I try to uninstall 1.02 and 1.01 ,after that I reinstall 1.01.Virta still shows 1.02 with I can not use 1.01 anymore.

The demo will not install over a newer version. I think you can use the uninstaller that came with the 1.0.2 installer. or simply remove the virta.DLL from VSTPLUGINS.

Hi Randy,I just installed 1.01 successful.but the problem is still on 1.01.
thanks for fix it on the next upgrade:-)

I seem to be having this same problem in Live. I can see input level all the way through Virta but can't hear any output. When I switch Virta on and off, about 1/3rd of the time, I get sound but then nothing on next patch etc.

I'm in mac 10.10.5 Yosemite, and latest version of Ableton.


Ps My sample size is 512 right now in Ableton.


Hm, seems to happen when I push the voices beyond 2, as in from 3 on up I get no sound and have to restart virta. I'll try it on my home machine which is a bit more robust than my work mac and let you know.


ps Unless I'm doing something really silly?

Sounds like possibly the bug that I introduced with Virta 1.0.2. Please try the beta version available here:

And let me know if things get better.

OK thanks Randy, I'll let you know.

I'm running the latest demo version and I get the same bug as in the opening post. Upon loading a project Virta outputs no sound.
Once I change the preset Virta functions as intended and sounds absolutely wonderful.

If changing the preset fixes it, this is likely a different problem. It could be that the default patch makes no sound in the DAW setup you are using?

Hi, I also have this issue.
It occurs over time.

The default patch works fine in the beginning, then abruptly the audio will stop processing and the output stage will show no output.

Only removing the broken plugin will fix it. Closing an affected project and reopening it does not fix it. Still no sound will occur.

I will try saving the project, closing live, and reopening it - if it is still broken then it must surely be a problem in the "interface state" logic, or something? Just a guess.

Windows 10
Ableton Live 9.7
i7-6700 with auto overclocking
32Gb Ram

Additionally when the audio input drops to nil I get a click on the output. This occurs on seemingly all patches. I run at 96k on an Audient card if that matters via ASIO.
Many thanks, maybe I can gate the click at a pinch but it is a royal pain really loud click like the bit calculation of 0 input is wrong or something.

In terms of cpu usage I can make single patches lock up the machine with almost nothing else running as accompaniment. I would say very high right now. I have Manipulator, and Voxsynth and they manage okay on the box to give you a sense of performance. Thanks

OK, thanks for the report. I'll see what I can do to reproduce this.

Virta at 96k is going to be a beast, but I'm going to make it better over time.

first of all, big fan of Madrona Labs! thanks for your work.

I have the same issue described by the original post:
When I open an Ableton project that had a voice with Virta VST, Virta doesn't play any sound, (it shows input signal though) and it works only if I change preset and load again the preset I was using.

It has the same issue if I'm using it as Audio Unit.

I recently updated to Virta 1.9.5 and the issue seemed to have disappeared the first days, but now it's back again.

MacOs Monterey 12.6, Ableton 11, Virta 1.9.5.

Thanks for your help!

EDIT: the issue seems to happen only while processing audio tracks, midi instruments seem stable.

Are you using the 256-band vocoder? That one has a bug where it won't work if the plugin loads with that option selected. Switching off the 256 band mode and back fixes it every time for me. If that's the issue you're having, Randy is aware of it.

I'll see what I can do about an update for Mac and Windows ASAP.

Thank you so much, yes I was using the 256 band mode, and switching it off and back fixes it :-)

Hi Randy,

just got both Aalto and Kaivo in my hands and these seem to be indeed awesome instruments.

Aalto seems to work flawlessly, but with Kaivo I have a quite similar issue as described above. When I change preset from the default, or change randomly either Resonator model or Body model, the sound disappears. I.e. no activity in the output's oscilloscope. If I disable the plugin in Live and enable it again, sometimes the plugin recovers and sound returns with the selected resonator or body model. But in the current state Kaivo is unusable for me, so please check it along the Virta.

I have MBP M1 running Monterey 12.6.1, Ableton Live 11.2.6 and tried Kaivo version 1.9.5 in both AU and VST formats with the same results.

I'm ready to help with this by running debug versions, etc, if needed.

Hi @sntr,

Thanks for the clear report. I'm also experiencing infrequent loss of sound like you describe, with the latest version of Kaivo. I'll work to fix this ASAP.