ForumsSoftware ← Seaboard + MBP 3.1GHz i7 + 16GB RAM + Bitwig + Kaivo + 512 samples = lots of crackling noise. Why?

Topic explains it all. This is top of the line MacBook Pro 13" 2015 and I play on Seaboard RISE 25, all my software is up to date, there's no expensive background processes, no CPU expensive software running in parallel (I even tried to close everything besides Bitwig to find the issue), charger is connected, battery charged and there's so many artefacts with most of patches that it's just unbearable.

Setting buffer to 1024 samples seem to help, but I start to notice the lag way too much - I can't express myself like this.

Is this kind of performance expected? Do I need a monster computer to run Kaivo?

I only run demo so far, but I wish I could pull the trigger and buy it as it's so good. Currently I'm not sure because of these issues.

there is white noise in the demo as 'protection' ( happens every now and then, a minute or so?) ... but its noise not crackling, but perhaps thats what your hearing?

only thing I can suggest (as a test only), is 256 samples, single voice on default patch... do you hear it, if so I'm guessing it must be the demo noise.

(others have confused this when demoing the software)

I run on both an i5 and i7 (Kaivo/Aalto) at 48k SR/128 samples without issue using MPE (and OSC) on a soundplane and eigenharp, so you definitely shouldn't have issues. OSX 10.10 and 10.11 both fine, and Ive used Bitwig and its ok, though not my 'regular' host.

I assume you have equator running, so that should prove the setup.

EDIT: apologies, whilst the iMac is fine, I checked the setup on my MBP, and when I switched it to 48k/128 samples it does have the issue. sorry I don't use it much for audio purposes

Thank you thetechnobear. The noise I was referring to is not the "protection noise" unfortunately.

As for your test. Without MPE with default patch I can go as low as 64 samples without any artefacts (for one single continuous note). But for example "agree to disagree" pad for the same single continuous note without MPE works clean on 512 samples minimum - anything less and it gets bad.

In general for me to feel confident, play multiple notes (nothing crazy), with MPE I need to set the buffer to 1024 samples, but sadly at this point it becomes unplayable.

I wonder what is going on. Some Kaivo presets do use a lot of CPU, that is for sure. But all of them run without crackles at more reasonable buffer sizes like 256 on my Mac, which is a mid-2012 MBP.

This thread is a perennial favorite:
But I don't think it really addresses what you are seeing.

Maybe there is an issue with graphics. Try turning off the animations in the "gear" menu, and try it with the plugin window closed.

I ran 'agree to disagree' at 128 samples in BWS 1.3.6 , OSX 10.11.4 no issues, could use all 8 voices without crackles. (latest version of Kaivo)
fyi, I checked my iMac , is an i5 2.9Ghz,

have a look at the DSP graph in BWS thats got a reasonable amount of information. (as you can see load over time, peak loads etc), from that I can see 8 voices are on the limit, as whilst average load is below deadline, the peak load with many touches starts to reach deadline (though in fairness I dont hear crackles, but the assumption is, push it further and I would)

from that graph, you can also see the effect of increases samples, doubling for me, almost halves the load.

are you using an audio interface?

I'm wondering if it's an issue with the Roli MPE data triggering something like a parameter change really often. Can you try the same patch with and without MPE?

Hello and thank you for all the input so far. Sorry it took me a while to respond - there's a holiday in Poland and I was away.

So, it turns out that ROLI, MPE etc. had nothing (or little) to do with it. Here's what I did: I disconnected all my controllers, I closed all the apps, restarted Bitwig with clean new project, removed unnecessary tracks, created just one with Kaivo on it, I did NOT enabled "force MPE", I disabled animations and even numbers within Kaivo settings (I also clicked a plugin size reset), Kaivo is set to MIDI protocol only (not MIDI MPE), I then created one continuous note using piano roll and looped it. I selected "agree to disagree" patch (but it's the same for others) and I just hit play with various buffer settings. I was looking at DSP graph also.

And the results are these:

  • for 512 it's mostly smooth but if I do as little as to move my mouse over tray icons or anything really - it often (not always) triggers some crackling. Not usable in real life.
  • for 256 it's non stop crackling, but sound is clear behind.
  • for 128 crackling is so bad it affects the timbre :)

Oh, I am not using audio interface currently as I am away visiting home town for holidays. It's a built in audio card.

I'll try it in Ableton Live next and let you know (it's my default DAW really, but for recording MIDI of Seaboard performances I tend to use Bitwig 8-track).

Ok, I did the same for Live: only one track, animations disabled (although they don't seem to make much difference), looped noted created with piano roll, same patch selected etc. And the results are:

  • 512 no problems at all
  • 256 it crackles once in a while. sort of usable, but not really, because every minute or so (sometimes much less) I guess that CPU will get occupied with something slightly and the sound will break down. it's just not a stable performance.
  • 128 obviously bad, but for comparison: it's better than 256 in Bitwig

Since I'm back at my place: I work with audio interface now (focusrite scarlett 6i6) and it changes nothing. So I guess that there's something about my hardware that just isn't compatible with plugin's code. I understand that my report isn't very helpful, so I'll wait for other people to report similar problems and if there aren't any then some time in the future I will try to reinstall OS X clean and try again. Thanks!

HI there, apologies for jumping in.

I have a Mac Pro 3.4ghz 12 core machine, and in LIVE 9, Kaivo really struggles at lower buffer settings - even at 44.1 - usually I work at 88.2. It's almost impossible to use it at 128/256 when I have hardware machines involved, and usually i have to do the Kaivo work initially, bounce and get rid of it in order to continue.

I have followed other threads on this topic and done my best to mitigate the adverse affects on my system, but it's a real struggle.

It would be amazing to be able to push this incredible software without restriction, but i understand that there's CPU intensive alchemy occurring under the hood. It's the only reason preventing me pulling the trigger on the other plugs.

Any plans to revisit the code would be gleefully received :)

Echoing this. I registered to post. I have a similar machine...early 2015 rMBP with 3.1 GHz i7, 16GB of ram and a 1TB SSD. Kaivo and Aalto both crackle like mad. This occurs with the built-in audio devices and my new K-Mix interface. At first I thought it was limited to just bitwig but it also happens in live. I have yet to use the AUs in GarageBand but I will try tomorrow.

I think it does have something to do with graphics. The crackling gets bad when the wallpaper changes or new windows are opening, etc.

I have tried an snc and a PRAM reset to no avail.

ok, I can confirm MBP i7 with 48k/128 samples also crackles here..

so I decided to run a few tests, in both BWS and Live (AU & VST) , definitely the MBP has an issue even with the init patch (voices = 8).
its not down the raw performance, as the MBP is much more powerful than my iMac i5 , and Ive also now set the MBP up properly, so its not a setup issue.
(I don't use it much for audio, hence id not noticed it was running a 256 samples buffer at 44k)

BWS DSP graph, shows clearly the issue is not really performance, as much as 'jitter' i.e. occasionally Kaivo, is taking too much time to process the sample buffer, but not consistently.

all dial animation was off, and actually appears to make no difference, however, my testing shows it does appear to be graphics related, (as @geremy also pointed out).

so I ran some Open GL GPU tests, and found interestingly, that whilst the MBP has generally better performance than my iMac, I can see with these tests, the test occasionally 'stutter' which they do not on my iMac.
my suspicion therefore, is that openGL is not as 'robust' on the laptops

this leads to one possibility...
its a 'known' issue that retina displays on the laptops are scaled, which is sub-optimum for GL performance. (the reason, is otherwise the display is tiny ;))
what would be interesting is to determine if this is particular to retina displays...

does anyone have a non macbook pro, that is using retina?
what would also be interesting is for someone to test this, by switching their macbook pro to native resolution temporarily (2880x1920), using one of the native resolution apps
e.g. switchresx (you can use it free for testing)

this is best done by someone on 10.10 or below (which is why I cant do it, as I'm not 10.11) as otherwise you need to display SIP which is a bit of a pain.

if switching to native resolution makes the glitches go away, we know the cause for sure....
it will still need to be fixed for sure, since its not practical to run MBP at 2880x1920 unless you like using a magnifying glass ;)

Note: I will say, if I use 48k/256 samples I don't get issues, so not as bad as the original poster.

So I tried in garageband and it crackles there too.

I downloaded a resolution switcher (RDM) and ran in the un-scaled native resolution (2560x1600). No real change. Still crackling.

To be clear I don't think this issue is Madrona Labs software specific. I can get this to happen with ABL3 and the like as well, so it is definitely an Apple issue.

Im not sure id agree with this:

To be clear I don't think this issue is Madrona Labs software specific. I can get this to happen with ABL3 and the like as well, so it is definitely an Apple issue.

Any VST 'could' produce audio glitches on any platform... its down to how the VST is written, and specifically about ensuring processing is completed in the time.

The issue is, Kaivo runs perfectly on my less powerful iMac... so it clearly is not cpu bound.

from reports here, its seems reasonably clear it something to do with the MBP setup... and laptops usual weakness is graphics hence considering openGL as being a culprit.
(and my openGL tests kind of indicated this too, jitter is the real enemy of 'realtime' programming)

personally, for me its not a big issue... as i said at 256 samples @ 48K SR it works ok for me, and I also have my iMac which is where I do most of my playing anyway.

but its bad for the the original poster who, has with a more powerful MBP, but is having to run at 512 samples. 512 is not good for real time playing , its ~ 10mS, where you don't want to be over 5mS really ,especially for something like a Seaboard/Soundplane

anyway, I was merely correcting my initial statements, as I thought it was ok, on the MBP which was potentially misleading. hopefully, the more info Randy receives, the better position he is to resolve the issue.

For me it is t just Kaivo, but Aalto and Virta as well.

I also tried it @ 256 samples, 48KHz. The crackling got much worse.

apologies for jumping in.

Quite the contrary—thanks for taking the time to send some information.

In order for all these reports to be most useful, we need to compare like with like. Kaivo takes up much different amounts of CPU based on what models you are running, and of course how many voices. So can everyone please use this as a test:

  • run Ableton Live (if you have it)
  • use built-in audio
  • set buffer size to 256
  • make one instance of Kaivo
  • select preset Kaivo keys/dulcimer (8 voices)
  • make sure animations in Kaivo are on (dial needles jumping around)
  • play some stuff
  • select "About this Mac" and report OS version, processor and graphics
  • report Ableton’s DSP meter
  • report the %CPU for Live in Activity monitor
  • move, resize, change focus of Kaivo window and report severity of glitches, if any.

You can copy and paste from the "About this Mac" window, but annoyingly, only one line at a time.

Example results for me here:
Macbook Pro (Retina, Mid 2012)
Processor: 2.6GHz i7
Graphics: NVIDIA GeForce GT 650M 1024 MB
Ableton DSP: 48-50%
% CPU: 60-61%
no glitches.

If there are glitches:

Please try the exact same setup with the plugin window closed, and let me know whether the glitches stop. This will narrow the issue down a lot. NOTE: if using Ableton Live it is important that you actually close the plugin window instead of hiding it by switching to another track, otherwise the window may continue to eat resources.

Please try reducing the number of voices to 1, with the window still open. Does that stop the glitches? Any Mac capable of running 10.7 should have no problem with this, so if it fails, we might have a good test case I can look at.

It's clear that though Kaivo works well for most of us there are some machines where something bad is happening. It seems like, if anything, these are more recent and powerful machines. If I think on this for a while that may be a clue. It's obviously a huge priority for me to get my software stable and reliable on all these computers. As I don't currently have one of them your help is appreciated. I may send out some beta versions or test programs for you to try soon.

Ok, so here are my results…

OS: 10.11.4 (15E65)
MacBook Pro (Retina, 13-inch, Early 2015)
3.1 GHz Intel Core i7
16 GB 1867 MHz DDR3
Intel Iris Graphics 6100 1536 MB

With given settings (and I used a regular keyboard to play - not Seaboard) and plugin window open:

CPU Load Meter shows anything between 60 and 75%, usually in the middle, so around 67-70.

Activity Monitor floats between 105 and 125% of CPU load (I guess that the total value is 100% times the number of cpu cores, because only then it makes sense).

Results: Very very bad, a LOT of crackling

With the plugin window closed:

CPU Load Meter possibly drops a little bit, by around 5% maybe, so it swings anywhere between 55 and 75, but often it is lower than before, mostly under 60%.

Activity Monitor shows a significantly lower numbers, between 60 and 80, usually lower than 70%.

Results: So much better, almost good enough, but still I get too many crackles to find it enjoyable, certainly not good enough for public performance - every few seconds (2-5 seconds) theres a few “artefacts”. Everytime I cmd+tab to a different window etc. there’s also a significant “breakdown” and there’s a LOT of crackling noise for a second and then everything goes back to normal.

With voices number set to 1 there are no glitches at all, I couldn't notice even a single one, CPU Load Meter shows numbers around 12-18% and Activity Monitor around 55-65% of CPU load, so very similar to 8 voices + windows closed situation. When I closed the plugin window then Activity Monitor dropped even more, to around 15-25%, but no change on CPU Load Meter in Ableton.

thetechnobear is definitely onto something! I connected my computer to an external display 1920x1200 over HDMI cable and then closed the lid to turn of built-in screen and it helped profoundly. Glitches almost stopped for 8-voices setup with or without plugin window open. I can still hear a crackle now and then, but that maybe happens every 10 seconds or so. I pushed my luck a bit and tried 128 samples, but it's still unplayable.

OS X El Capitan
Version 10.11.4
Macbook Pro (Retina, 13-inch, Early 2015)
Processor 3.1 GHz Intel Core i7
Memory 16 GB 1867 MHz DDR3
Graphics Intel Iris Graphics 6100 1536 MB

With 256 samples, the plug-in window open, and the aforementioned preset, not even 1 voice plays without crackling. Live's DSP meter hovers between 80-100%. Activity monitor reports anywhere between 85-120% CPU. Closing the plug-in window has an immediate positive effect. 1 voice is almost doable. DSP meter drops to 60% and activity monitor %cpu drops to 66-72%. Still lots of crackling though!

One last thing: every other plugin I own, including u-he ACE, ROLI Equator, Pianoteq, TAL emulations of Juno60 and 101 and it all works flawlessly with buffer of the size of 128, possibly even less (I didn't investigate in details, so maybe for extreme cases it wouldn't be good, but in general it works great!). Also, Aalto doesn't work very well either, so some code must be shared between these two that causes this (at least part of it).

Macbook Pro (late 2008)
OSX 10.7.5
Processor: 2.53GHz Core 2 Duo
Memory 8GB
Graphics: NVIDIA GeForce 9400 - 256 MB
Ableton DSP: 85-90%
% CPU: 75-85%

8voices plugin window open or closed of course it glitches (it's not fair), BUT can handle 6 voices plugin window CLOSED with all asked settings, clear sounding.
Ableton DSP: 60-65%
% CPU: 70%

the above was using Kaivo 1.2.0 - sorry

MacBook Pro (Retina, 15-inch, Mid 2014)
2.5 GHz Intel Core i7
16 GB 1600 MHz DDR3
NVIDIA GeForce GT 750M 2048 MB

SR 48000, 256 buffer
Live 9.6 64 bit
Kaivo 1.2.1, VST

Plugin window open:
CPU ~110%
CPU Live ~50-55%

as previously mentioned, no audio issues at 48k 256 except (very) occasionally, if I start doing other work in ableton, e.g moving notes around the grid, or doing stuff in other apps, e.g. safari (to type this ;) )

Plugin window closed:
CPU drop to ~60-64%
CPU Live : same ~50-55%

still no glitches ;) in fact no change at all, working on other things, may cause occasional glitch.

if I drop sample buffer to 128, then I get some glitches, and still seems to make little difference if plugin window is open or not .

can I make a couple of observations:

thinks to check, perhaps to see if they make any difference...

i) I use the 64 bit version of Live, and 9.6
ii) Im using the latest version of Kaivo 1.2.1
iii) use on main power , or make sure in energy settings, automatic graphics switching is OFF.
iv) this might only be on 10.11 ?) in activity monitor, on the energy tab.. can you check that 'requires high performance GPU' = Yes for live.

likely wont make a difference, but important we are all comparing the same thing.


the notable difference so far, is my MBP is using the NVIDIA GeForce GT 750M, rather than the Intel Iris Graphics 6100. given the finger already pointing towards graphics, this looks a likely suspect.

(it may not be just down to hardware, but also how well the driver supports openGL etc)

my MBP is very similar to Randy...
Randy, does MBP start to break up occasionaly at 128 samples?, if so id say we are probably seeing similar. I guess this is 'kind of reasonable', except my iMac outperforms at lower specs, but hey, comparing laptops vs desktop performance is a whole different ball game!

So confess i have completely miss Kaivo 1.2.1 (either was in the middle of a project or at the time being not around this planet)

SO update to my post above:
64 bit version of Live, and 9.6
latest version of Kaivo 1.2.1
SR 48000, 256 buffer
fresh start, main power

Plugin window open:
CPU 90-120%
CPU Live ~90-95%


Plugin window closed: (makes the world of difference)
CPU drop to 40-50%
CPU Live : 85%

still glitches with 8 voices, BUT can get away with 7 voices ;crystal clear! so definitely improvements over 1.2.1.

Yes, my MBP starts to get glitchy with the test setup if I go down do 128 samples.

Thanks for pointing out the version issue Mark.

I would say that @keymanpal and @thetechnobear's experiences are in line with what I see here. The other machines reporting problems are taking up much more CPU than they should. They all do seem to have integrated graphics, which could be the problem. It also could be something else about these machines that is different.

I have two ways to work on this right now:

  • think hard, stare at code
  • get hold of a recent Intel Iris graphics machine for testing.

I'll do both.

The multicore work I plan to do in the near future should help machines like @keymanpal's a lot. But it is completely separate from whatever I need to fix to get the recent machines described here working as intended. I'll have to take care of this more fundamental issue first.

Oh by all means Randy "go take care the new machines"!
Only sent for comparisons and help in some way, it's an old machine that has served me well and in need of rest/other duties.

Thanks Randy! I just bought Virta in appreciation of your support.

Thanks for your support!

This is something to try. an AU component.

Recent builds of JUCE-based plugins in El Cap seemed to be having problems. There is more info here:

I had to remake the whole Virta build to get it to build in a newer version of JUCE with the fixes I need. Some features will not be right! Parameters will behave strangely. But trying some presets should be possible. Please do that and let me know if the glitches are better in El Capitan. Fingers crossed.

I tried it quickly but it was difficult to get output in live. I was able to compare the 1.0 VST @ 44.1KHz, 256 samples to the 1.0.2 AU and they were similar. This is with all built-in audio though. I will try again tomorrow with my interface and a higher sample rate. Thanks for the effort though!

So after trying several more times, it seems better with 4 voices at 48KHz, 256 samples. When I go to 88.2 KHz it falls apart. I can't seem to get output @ 88.2KHz, 512 samples.

I was able to try today with my interface (k-mix) and everything. 88.2KHz, 256 samples works very similar to the 1.0 vst.

I have to get Virta updated for other reasons so I was hoping this test would do something obvious. But it's possible this is only a problem with Kaivo.

I will go back either tonight or tomorrow and try with my interface 88.2Khz, 512 samples again. Thanks for the effort though!