ForumsSoftware ← Aalto 1.6 Imported presets

I have updated to 1.6 and converted my presets, but when I load them they are now showing as a default preset in a patch sense & not how I have patched them.
What to do?

I can verify this problem on my old 10.6.8 machine now. I will fix it ASAP.

Meanwhile, your old presets are where you left them. You can go back to Aalto 1.5 to use them.

I added a license for the Aalto 1.5 download to your account in case you did not save your installer.

Just so you are aware I am using 10.9.5


Having problems as well; my own presets are found but unavailable/inactive. When trying to convert/import them again and they disappear from the menu.

Hopefully I'm very close to a fix here. Meanwhile please email me at support if you need a 1.5.0 installer.

Ok, tx Randy. I´ll hang in there and wait for the fix:)

Unfortunately the update gets to about 15% and crashes every host I have tried this in.

I've reverted back to 1.5 for now

@swey, are you on 1.6.1? If so, I'm taking a wild guess that you have some preset file that is corrupted. You could try converting just one directory of presets and see what happens. If you can find a particular file or kind of file that seems to be causing the problem, please mail one to me at support.

And, as always, what host / OS versions are you using?

Yeah 1.6.1 on Mavericks - this happens with the AU and VST so I guess it must be the preset but it worked fine when I converted them with 1.6.0 (in that it didn't crash, even if the converted presets were messed up). However I have tried going back to 1.6.0 too and it now crashes too so I guess one or more got corrupted when I did the last convert - not good.

Maybe I will try and restore from a Time Machine backup.

OK that worked.

Now they are converted should I remove the old folder of presets as they will still show up in Logic's browser but I presume no longer work?

If you can find a preset file hat seems to be causing the trouble, please email it to me— I would of course like to guard against such problems. Sorry for the trouble.

In my opinion you can safely get rid of your old presets in the Library folders. Maybe try the converted versions first to make sure they are working well for you. But it sounds like all is well now.

Okay a work around for the preset problem!
In Live 9 you can still load your presets, if you have not removed them via your AU version of Aalto.
Once loaded you can resave them and they then show correctly within Aalto's own preset browser.


Wait, did you try the preset converter in 1.6.1 ? That VST version had the exact problem you started this thread with, and got fixed as I posted a few days ago.

Hi Randy.

I hadn't noticed you had posted another update with the bug fix!
So there is a 1.6.1 update I should try?

Sorry you didn't get the news. It's on the front page news here and on Twitter, and I will always post about updates in both those places.

Converter worked great for me in 1.6.1

hi, i'm on aalto 1.6.1 on mac osx 10.7.5

i need the aalto preset "bongo party" working by tuesday… opened my old set and soundplane would not control aalto. figured a lot of stuff had changed in the past months so updated to latest version of aalto and also soundplane client. now i can get the soundplane talking to aalto, but the preset in aalto will not load.

i click on "convert presets" in the drop down menu on aalto but a message comes up saying "no presets found to convert." i have double clicked both the installer for mac and updated to 1.6.1 which is confirmed by the text in the upper right hand corner when i open aalto in ableton live, and i have also double clicked the aaltopatches package in the installer folder and they say they install successfully.

can you please tell me how to get bongo party working in the percussion presets? trying to play it with my soundplane in shows on tuesday morning… thank you.

Hi Jay, is OSC enabled? are you seeing "receiving t3d" at left? Do the other presets work?
If not, go to the drop-down "gear" menu and turn on OSC. You can also select a port offset—0 should be compatible with previous versions.

I just tried all the versions you are on with the bongo party preset and it works OK here.

You may want to do the "normalize" procedure with the new Soundplane version. I am telling people that for improved finger touch at edges anyway. With juggling balls and a high threshold it probably doesn't matter.