ForumsNews ← Aaltoverb 2.0 public beta

Img 3885

I’ve made a beta of Aaltoverb 2.0 available on the site here as both Mac and Windows installers. Links are below.

I’m excited about this release because it’s the first rollout of a whole new framework I’ve written as the technical foundation for my plugins going forward. This will enable fast animations so I can make the fun and informational UIs I’ve had in my sketchbook for a while but was not able to put into products.

When the pandemic first hit I was playing video games regularly for the first time in years. In console games like Animal Crossing and Breath of the Wild I saw a lot of cool interface concepts that were fun to look at and also very usable. “Why can’t we have these nice things in plugins?”, I asked… kicking off at least a year of work.

Feel free to grab the software and try it out. And if you have time to contribute by writing quality bug reports, or sending your thoughtful feedback on the new features, please sign up to the Discord to do that.

In addition to the new graphics layer, Aaltoverb 2.0 provides Apple Silicon compatibility, MIDI learn, an LFO per control, a patch browser and a small collection of example patches.

The 2.0.0 beta release seems solid but as with any beta software, use it at your own risk and not in crucial projects! If you’re more tending towards caution right now, the release version should be out soon.

Since the manual will take some time, I made a quickstart video on the new features. You can see that here: Aaltoverb 2.0 Quickstart

Aaltoverb beta links:

Discord invite link:

NOTE: I've had some trouble using the invite link in Safari. If you run into this, just use another browser to accept the invite.

AALTO is one of my top 5 favorite plugins of all time, so anything related to it is fine by me! I didnt buy Aaltoverb v1 when it was released because I didnt think it`d run on my Windows 7 laptop, but lo and behold.. v2 runs just fine!

I realize Win7 isnt supported, but Im ok with that!

Anyway, thanks for creating Aaltoverb.. and especially AALTO!

Nice job!

Works flawlessly in Linux with yabridge and native Reaper. A very inspiring reverb indeed.

Glad you’re working through this new framework using an approach reminiscent of UX.
Some of the affordances could really improve our experience with some of your plugins. Especially those with elaborate interactions between parameters.
Quickly scrolling through presets does enable something meaningful in terms of usage. This is one I wish other devs could emulate. Patchsurfing is the type activity that we end up doing haphazardly and it rarely provides us with the results we need. What the responsiveness adds, here, is a very direct feedback loop which really helps in appropriating the plugin. With something like Aalto, which has distinctive presets, it could make for an enhanced experience. (In fact, I’ve rarely used Aalto since buying it because it’s been hard for me to figure out when I can make the most out of it, with my MPE controllers.)
Speaking of which, your approach to MIDI Learn is also likely to help a lot, depending on people’s setups. While I probably won’t use this feature much (since my main DAW, Bitwig Studio, has a much better approach to modulation and MIDI assignment), I wish I had it in the past as I was trying to route my windcontrollers’ breath control to diverse plugins.
The extreme responsiveness of window resizing is impressive… especially in the #MusicTech context where very few devs have demonstrated a level of understanding of the problems caused by lack of responsiveness. Further, making such a simple plugin into a very small GUI element makes a lot of sense. I’d go as far as to make it even smaller than the minimum, exposing fewer parts of the interface.

In the interest of “User-Centric Design”, some things I’m less fond of…
The hovering dialog for the aforementioned MIDI Learn (and LFO): it grew old after a few minutes. It’s distracting at a time when I’m trying to set values. Not fun.
“Press-and-Hold” isn’t that bad (though it can be tricky to find the exact amount of time which will satisfy most people). Other gestures are closer to expectations, including “right-clicking” (two-finger tapping using my MBAM1’s trackpad). After all, there isn’t much of a logical connection between press-and-hold and the notion that you’re setting modulation for that knob. Sure, you could keep the press-and-hold for situations where alternate gestures are unavailable (which would be rare on current machines). It’s one of those situations in which it makes sense to have more than one path to the same part of the UI.
Though the file icon does relate to operations which have to do with files, it typically signals the creation of a new file. So its usage here generates surprise and decreases discoverability.
Speaking of file operations, maybe Aaltoverb is too simple to even give an impression of where things may go within your framework. Still, a large part of music plugins’ UX has to do with patch management and since it’s far from a solved problem, I wish your new framework provided some indication as to where things might be heading. Especially in the context of people sharing patches and patchbanks.
(Relatedly, your “version” feature might be somewhat useful yet it’s harder to understand when it’s only that word as opposed to “Save as version”. It’s also unclear how different it is from “Save as”.)

Overall, I do salute this work meant to improve the experience of using your plugins. Native support for Apple Silicon would be the main feature to make me update/upgrade (though it now feels like table stakes as most actively-developed plugins do run natively on M1). These UI/UX niceties could have a deeper positive impact on the way I use your plugins, leading me to purchasing more.

I'm just curious where the installer on windows is actually putting the vst file? I found the presets by doing a search for aalto on my drive but Reaper isn't picking up the plugin. Weird.

C:\Program Files\Common Files\VST3\Aaltoverb.vst3

I am liking it very much so far, but v2 has overwritten v1 and I cannot recover v1 in any way (I’d love that, since I have used v1 extensively in almost all my projects). I have tried reinstalling, but to no results. Is there a way to keep both? And if not, how can I go back to having just v1?

Hi! I've installed a.v. 2 and the gui is not working. I'm on 10.13.6 2011 mbp. Not a big deal because I'm going to buy a M1 this spring. Is 10.13 out of question?

@angy The AU is also not working here on a Mac Pro (Hackintosh) 10.13.6 in Ableton 11.1 (native AMD Graphics). But the VST3 works...

Wonderful and exciting! Thanks a lot for your work. <3

@maserna I'm going to fix the Windows installer to overwrite pervious verisons. Meanwhile you can remove the VST3 file from C:\Program Files\Common Files\VST3 and run the v1 installer (from the product page) to get v1 back.

thanks @atelierminceur.

@angy @klangfuchs the GUI requires Metal and this will work on some but not all 10.13 machines. ANy machine running 10.14 or higher is guaranteed to have Metal. I plan to work on an OpenGL version for Mac.

@andreya.ek.frisk thank you!

Thanks for the thoughts @enkerli. I'm working to make one set of behaviors that will work on tablets as well as laptops going forward. This may help explain some of the decisions like click-and-hold. I hadn't considered a two-fingered tap. I'll give it a try.

I never used Aaltoverb before, so I don't know if this is a bug or not.
From the other Madrona Labs plugins I'm used to double click a value to set it to its default.
Here, a double click will show me the default value but I actually have to click a third time in order to set it to that value.

I´m on High Sierra too, and it works for me as a VST3(MacBook Pro Retina 2014).
After a few resizing, i couldn't access the menus.
And it would be helpful, to have the ability to deactivate the LFO(yes, I can set the parameter to 0, but this is a step more).
Really liked the scrolling through presets.
Perhaps I should have bought this in last sale!

Hi Randy, I was eager to try out version 2 of Aaltoverb but couldn't get it to run on two Win10 systems. One with Cubase Pro11 and one with Cantabile. It installs regularly and is shown correctly under the DAWs but simply can't be inserted after selecting it. How that help and if you need more information, let me know. Cheers

Sounds so interesting what you wrote about Sumo. Looking so much forward to it. I still got my rarity, the Kawai K5 additive hardware synthesizers love to see your approach to that synthesis. I am sure you'll bring it onto next level in the box. Enjoy the process :)

Really liking the speed and look of the new framework/ui. One feature that I think still needs a bit of tweaking is the preset menu functionality:

  • The mouse wheel (on Windows anyway unsure about mac) to scroll through presets seems a bit hit-and-miss (you have to spin the mouse wheel quite fast for it to actually move !)

  • Scrolling up and down with the left mouse button held down seems to be restricted by how much desktop space is available i.e. if you have the plugin near the top of the desktop and you click and drag up you can only scroll a few presets until your mouse cursor 'collides' with the top of the desktop and you cant scroll any further up (likewise if the window is near the bottom you can only scroll a few lines down until the mouse pointer reaches the bottom of the desktop). Perhaps the GUI can 'ignore' the pointer reaching the desktop borders and continues scrolling when the user continues to move the mouse moves up or down

  • With the few presets available with Aaltoverb the scrolling through presets isn't too problematic, though I can imagine if a preset list grows considerably (like my Kaivo and Aalto preset list), scrolling through presets as per this Aaltoverb beta method will take a while. Maybe the click and hold paradigm could be extended here so when you click and hold on the preset list a preset menu pops up ?


I'm not fully sure what failed when I initially installed this, but it failed to load for me - an unable to open error or similar .. tried in a few other apps to no avail

Reinstalled using the same download and it completed the same, but I elected to reboot for lack of a better idea and it was then all good on Mojave (2012 Mini)

Right now, I'm slightly traumatised by the insanely high noise 'watermark' - but in between those crashing waves I had a play with one error evident a few times but not every time a patch was changed - basically the 'needles' would freeze at the last settings, but the numbers and 'pie' would be correct - the needle would step back in line when tweaked - but not ideal as it creates confusion

As much as it's hard to flaw the aesthetic and substance of Randy's plugins and the glorious sounds which await your uncovering .. it strikes me as form over function to limit preset selection to scrolling - even if there were an alternative 'load' method which only engages the preset you were looking for it would be an enhancement - it looks 'neat' but it's not satisfying to audition a whole bunch of other presets en-route to the one you want .. unless I'm mistaken that there's a better way to 'browse'

imagine this in a live context !

every other instinct is right in terms of how these plugins are compiled and these are by far the most satisfying places to play with sound on a computer - but a choice, like the automatic loading-scrolling method, for me is hard to square up with the rest of the experience - even a delay on load would help, but I'm sure there is a more elegant way to find a middle ground - I must admit, I tried all modifier keys as I couldn't believe it was set that way

with a bit of luck my 10 y.o. mini will be accompanied by a 2022 one if these land at an affordable price point - I look forward to exploring this stuff on a music only machine with minimal s/w on it - the MadronaLab plugins are essential installs

if Sumu is destined to run on hardware like my 2012 Mini/Mojave then it'd be good to know and try out, I'm assuming the processing requirements may be beyond the old mini or even that Mojave will be an issue - but happy to see that this plug runs on it and after an install glitch seems to be fine (for both au and vst3) - besides the needles graphics glitch

With the few presets available with Aaltoverb the scrolling through presets isn't too problematic, though I can imagine if a preset list grows considerably (like my Kaivo and Aalto preset list), scrolling through presets as per this Aaltoverb beta method will take a while. Maybe the click and hold paradigm could be extended here so when you click and hold on the preset list a preset menu pops up ?

I'll be adding this at some point. For Aaltoverb I reasoned that people aren't likely to have too many presets around.

Thanks for the other info, these are things I will fix.

Hi @avantronica,

As you found, rebooting is sometimes needed to get new AUs to install properly. Nobody I know has a good solution.

The demo noise didn't seem too loud to me—that wasn't my intention. I can make it softer.

As noted above I plan to add a popup patch browser. Not sure about version 2.0.0, but this will definitely be needed for Sumu, and I'll add it to Aaltoverb as well.

I'm waiting for a 2022 Mini also, I hope they will show it next week!

@nichttuntun please give me more information about what happens on these hosts that prevents it from being inserted. You see the plugin in a menu and try to insert it—what happens instead?

also, I'm afraid I don't have either one of these VST hosts—which is not your fault—but is there a chance you have one I do have, so we can test the same thing and see if it is specific to those DAWs? I test in Ableton Live, Bitwig, Reaper, and FL Studio on Windows.

Hi, all seems completely normal. I click an empty insert slot, the plugin folder list opens, Aaltoverb2 is displayed, I click onto the name. Usually now the plugin would load into the insert slot and the plugin-folder list would close. In this case the plugin-list closes and nothing else happens. The insert slot stays empty in Cubase.

I had Aaltoverb1 installed priorly, but de-installed it completely beforehand. The new install worked fluently and it showed up in Cubase correctly. Aaltoverb1 worked fully functional. Could it be that there are some things left over after de-installation, which distract a proper working Aaltoverb2?

Let me know if you need some more information.

I'll fix the installer to install v.2 over v.1 and then maybe you can try it again. Removing the VST3 itself should be a complete uninstall. The license and patches may also be present but these can't confuse a plugin into not opening.

If you can scan the plugins in Cubase, maybe it will give you some more information?

Yeah - my AU doesn't work on a MBP M1 Pro in Ableton 11 Beta but the VST3 works fine.

I would try restarting. Sometimes the AU needs a restart to get properly registered.

@Randy, thank you. I try again and feedback to you afterwards. Cheers

Hi. I got it to work on Cubase but after a short while it caused an exceptional error which brought Cubase to hang.

All in all, the sound is awesome. It's a great addition to give all parameters LFO. I'm in love with it overall. Very well done.

The graphical interface and kind of functions are fun to use but also slowing down workflow as submenus in my opinion belong to the days of 80th digital hardware synths and rack extensions.

For example it's awkward to press longer on the parameters to open the submenus. A negative side effect also is while doing so, you change the current values as the values follow the position of the click.

I'm a ongoing mix engineer and in mixing its all about going fast and many times back and forth to only change small things. It's not good if you put many efforts in tweaking huge chains of AUX tracks and than realize that one track could have a touch more modulation, going there and literally have to re-arrange everything again.

From an engineers perspective I rather see the context menus under the dials, layed open. So having a all in one GUI on one page. As Aalto verb is so small and doesn't have much features that shouldn't be a problem.

A second thing that I find very important is the metering. When building huge AUX chains there is nothing more important as that the plugins are driven with a appropriated level. It's difficult to know from the avaible input meter whether it's RMS or Peak level and I'm missing the values read out or more clearer indication numbers. Metering could be a bit bigger also.

As fun the new GUI features are (I really do like them a lot from a design perspective), from a professional point of view I don't see them too much useful for accurate and fast workflow.

That's my first impression. I hope you find this constructive. Cheers

I thought further about it - as I really like the fun implementation of the pop-up style design.

Why not put a small knob under each big knob to pop-up the menus. That would prevent the high value changing jumps and keep the GUI clean enough. It would also save time as the pop-ups would be there imidiately when klicking.

I nevertheless would like to see all selected data directly under the big knobs as it helps a lot to keep overview in very big projects. But that could be a good compromise.

One suggestion for the people who are easily getting motion sick watching certain things on screen. Imo an option in the settings to disable the moving effect of the pop-up windows could be a welcome addition.

Hope you are not offended. I'm beta testing since some time now and I really only commit in such a way when I'm convinced about the quality of a product and that the developper does it out of passion and is thinking out of the box. So I really hope you see that as a positive and constructive contribution. And please relax. After all it's your product :)


Thanks for your contributions @nichttuntun, of course I'm not offended.

People have a lot of different ways of approaching the products and things they want from them. I can't please everyone. So I try to take in all the information about what people want as just that: information. It will probably only affect the design if I hear the same thing from at least a few people. One person can always point out something I overlooked though.

In this case I've heard from more than a few people that a way of getting the submenus up without any delay is needed.

The meters do not show a lot of information—my intent is not to overwhelm. They should be accurate though. The red light should go on at 0dB. I just looked at the code to remind myself: they are RMS levels with a 1ms integration time. As I write this I'm actually changing that, because a much longer time on the order of 125ms is more typical for an RMS meter. I think this is an improvement.

I also looked at the levels in the code and it seems each light was a 5dB step. Weird, and just an error on my part. I'm changing this so that they will be 6dB in the next version.

One small thing i've noticed (on m1 macbook) - setting lfo to sync displays nan for the ratio dial. Perhaps the display text could be updated to something less technical for users in this case?