ForumsNews ← Virta 1.0 is released.

Finally the newest Madrona Labs device, Virta, is out in the world. I hope you enjoy it.

Please head to the product page for sound demos, demo plugins, and of course that handy green "Buy Now" button. Thanks for your support.

Great work and congratulations!

It seems awesome but the demo doesn't work on my computer ! A 2009 Mac Pro. I tried the demo with Mac OS 10.8 and Mac OS 10.10.5, and it won't work on both ...

The synth isn't recognized in my DAWs ( Renoise and Logic Pro X ), but the component is present in the library.

The demos of Kaivo and Aalto work fine btw.

Could you please help me out ?


-- EDIT --

Sorry, I thought it was a VSTi like your other stuffs... It works fine since I checked in the effects folder -.- Sorry for being dumb and congrats for the great release. Playing with the toy now.

playtime finally :]

thanks and congrats!

Randy, looks and sounds great. Any coupon codes for owners of your other software available? I haven't seen any email announcements and never hurts to ask. Thanks, Scott

Congrats on releasing Virta. Excited to finally be playing around with it.

I am however encountering what seems to be some strange behaviour in regards to feeding audio into Virta using Reaper. While I can tell there is audio running through Virta coming from the "pre" output by patching that straight to the aux input and watching the scope, none of the other outputs from the audio module seem to be responding to the audio signal input and the meters at the top don't respond either. I'm pretty confident I have the routing configured correctly in Reaper but I'm at a loss so far as to why the audio module isn't working as described in the manual. I'm also finding that the audio I'm sending through Virta always comes out even with no patch connections. Just wondering if any of the testers or anyone else now, have encountered anything similar? I'm running Virta 64bit, Reaper 64bit on Windows 10 using a MOTU Ultralight mk3 audio interface for what it's worth.

Teezdalien: I'm getting the same issue in Live (and indeed in a brief check with the Reaper demo).

Audio is coming through the 'pre' output just fine, but none of the other audio module outputs are doing anything. I'm able to patch the 'pre' output around as you'd expect, and I've got no trouble getting MIDI in there to patch around, so pretty sure the routing is all set up correctly. At a loss as to why I'm getting no output from any Audio outlet other than 'pre' (even 'comp' doesn't work!). FWIW the lights on the 'pitch' and 'peak' outlets are stuck on while the others are stuck dimmed.

edit: I get constant dry signal in Reaper too incidentally - missed that. I'm not familiar with Reaper at all though so I just assumed I was doing some aspect of the routing incorrectly. Other than the dry signal being a constant presence, I have exactly the same issues in Live with the audio analysis module.

At a loss as to why I'm getting no output from any Audio outlet other than 'pre' (even 'comp' doesn't work!). FWIW the lights on the 'pitch' and 'peak' outlets are stuck on while the others are stuck dimmed.

This sounds like the input filter having blown up. I made a somewhat last-minute change there so I'm pretty sure that's it. it matches the symptoms. I'll have to take a look at this when my head is clearer tomorrow.

You can expect an update for this and any other release glitches later this week.

Any coupon codes for owners of your other software available?


Thanks Cron, seems there is an issue somewhere. Like I said I'm pretty certain I have the routing set-up correctly, but I'm wondering if it may have something to do with how Reaper handles tracks and routings, as it doesn't discern audio from midi etc. like other hosts.
I also have the constant dry audio feeding out without any patch connections made in Virta also. I don't have any other 64bit VST hosts to try with at the moment either. I will try the 32bit VST in Max7 and see how that runs.

edit: Thanks for chiming in Randy. Looking forward to the fix.

Yes the dry signal is always coming through in Reaper, confirmed here. Reaper sees Virta as a vsti instead of a vst amd this could be the cause. When using Reaktor for example, running the vsti version always has the dry signal pass thru whereas the vst version of Reaktor does not pass thru the dry signal. Possibly something to do with how Reaper uses 1 track type for both midi and audio.

Many thanks for the quick response Randy.

That sounds like the one! I'd noticed that switching presets yields a (thankfully controlled) explosion of sound, and I recall one of the 'stuck' audio outputs 'pegging' the modulation target to its max possible value when I tried assigning it.

I've had tremendous fun playing Virta as a straight(ish) vocoder in the meantime and look forward to getting a fuller taste in the days to come.


"Reaper sees Virta as a vsti instead of a vst"

yep, that's the cause. In other words, on Windows it's very unlikely that the current VSTi version of Virta will work. On Mac (AU) it works of course.

Maybe this should be explained a bit how this works in Windows: there are VSTi's with audio input, but to use them as an insert, there must be an extra VST version. Only then it will work as an insert effect. That's why there are two dll's for such instruments.

But there's no hurry. For me at least.


I had the same problem in Reaper; No audio in except through the pre. I don't recall ever having problems running audio into a VSTi before, so I don't think it's inherently Reaper's plugin protocol, but I could be wrong.

@Randy enjoy this a lot :)

a small feature request (and one that goes for Aalto/Kaivo too)
can you please reduce the length of the parameters names...

On a Ableton Push 2 , it can show about 15 characters ( 8 on the Push 1) , and because you prefix the parameter names the 'meaningful bit' often gets truncated. so often parameters look identical. this is a real pity, as its a great way to mess with Virtas settings without having to use the mouse all the time.

(Im not sure if vst/au support long and short names like M4L does, but that would be ideal solution)

another small one, it would be nice to have both a VSTi and VSTfx version, the former then could be popped directly onto midi tracks when using in 'synth mode'

anyway, back to having more fun... not even tried audio mangling yet, purely being using as a synth so far ;)

"Reaper sees Virta as a vsti instead of a vst"

Ok, I think I see the same problem on Cubase 8.5 Pro (Mac)
Virta is listed as a midi instrument, but not as an FX so cannot be placed on an effects track....
has anyone got this working in Cubase?

(I'm a newbie with Cubase, so perhaps Im missing some way to get audio into an instrument track)

I have it working on Live absolutely fine... switched to cubase as wanted to use MPE.

yeah I'm having the same problem with Cubase, any thoughts?

cubase: doesn't look possible, as far a I can see

see :

congratulations randy, virta is amazing!

yes it's an absolutely great plugin. Many thanks!

Very well done! Thank you.

"the dry signal is always coming through in Reaper"

I'd like to get Virta (to add to my Aalto and Kaivo), but having the constant dry signal in Reaper is a big problem for me.

Yes of course, I'll see what I can do about it.

Thanks, Randy!

Any progress on the VST-FX version of Virta? I feel hesitant to buy it until I know it works in my main host Reaper.

There is a workaround for reaper posted in the DAWs thread:

I just tested and this works for Virta and Reaper on Windows:
You just need two tracks and some custom routing.
I also posted over at the Reaper forum.

Multiple people have reported success with this.

I have two other important bugs to look at for the the first update, so I'm not releasing a VST fx version right away, it may be a week or two.

I will definitely be purchasing Virta on pay-day!!
Thank you so much for another beautiful instrument. Big fan!! :-)

Thanks Randy. I felt confident enough and just bought it. :-)