ForumsSoftware ← Why can't I open Kaivo in Logic Pro X?

I've tried half a dozen times to install and load Kaivo ver 1.9.2 into Logic Pro X and it will not open. I had Kaivo ver 1.8.3 installed and it worked fine, then I updated to 1.9.2 and now no love. Here is the error message that Logic's plug-in manager throws. Please help!

validating Audio Unit Kaivo by Madrona Labs:

AU Validation Tool
Version: 1.6.1a1 
Copyright 2003-2013, Apple Inc. All Rights Reserved.
Specify -h (-help) for command options

VALIDATING AUDIO UNIT: 'aumu' - 'Kaiv' - 'MLbs'

Manufacturer String: Madrona Labs
AudioUnit Name: Kaivo
Component Version: 1.9.2 (0x10902)

* * PASS

2019-12-07 16:42:09.750 auvaltool[44500:4641990] 16:42:09.750 ERROR: >compload> AudioComponentPluginLoader.cpp:513: ResolveFactoryFunction: CFBundle 0x7fd518c16c10 (bundle, not loaded): cannot load bundle: The bundle “Kaivo” couldn’t be loaded.
FATAL ERROR: OpenAComponent: result: -1,0xFFFFFFFF

validation result: couldn't be opened

Sorry you're having trouble. Can you tell me what version of MacOS and Logic Pro you are running?

Thanks for replying. Mac OS 10.10.5 (yosemite), Logic 10.1.1

I just deleted all Kaivo-related files, re-installed, then rescanned all the audio units on my computer by removing the audiounit cache files from the library folder, restarted the computer, opened Logic, and when Logic ran the scan this popped up:

While verifying Audio Unit compatibility, Logic Pro X encountered 1 Audio Unit plug-in(s) which did not pass the Apple AU validation. These plug-ins have been excluded from further usage in Logic Pro X to prevent possible problems or crashes. You can start the Plug-In Manager now to review the validation results or continue the startup process.

I have no more ideas what to try. Any suggestions would be appreciated. Thanks!

OK, that's a pain, but I'm glad you went through all that including removing the audio units cache because that's what I would have suggested next.

The only compatibility-related change to Kaivo 1.9.2 was the removal of 32-bit support. Since you're running Logic 10 this shouldn't be an issue for you.

When you have time, please open a terminal, type the command auval -v aumu Kaiv MLbs and send me the output. You can email it to me at . AU validation passes here, which I test before each release, and just tested again now to make sure. The output of auval should tell me what's going on on your computer.

I had a similar problem on Sierra a couple months ago. It turned out that Apple had released an update to the .mobile library (including openacomponent) that broke the framework for a lot of my plugins for a couple of weeks. Then they released an update which fixed it again. Yosemite’s no longer supported I don’t think, so if this is your problem as well...not sure what else to do besides update to Sierra.

Btw, reinstalling the same OS didn’t do a damn thing to fix it for me. I’m just lucky I saw that update before I set my laptop on fire.