ForumsNews ← Aalto 1.6.1 now available

Aalto 1.6.1 is out now for Mac and Windows. You can get it at all the usual places. If you have a license, click "my downloads" up there to get the link to your personalized version. If you want to try the demo, go to the
product page. Make sure to get the patches download if you're on Mac OS.

1.6.1 changes:

  • fixed a problem where parameter automation was turning off due to a loop.
  • Fixed "ghost window" issue on close in 32-bit Live
  • fixed issue with AU version not loading in Live
  • fixed errors in OSC enabled state
  • fixed a possible crash in the patch converter
  • patch converter on VST version was generating default patches from .aupreset - fixed

awesome stuff... OSC and automation working great here... thanks!

Still getting stuck notes in FL Studio. Was it supposed to be fixed in this version?

Not fixed. Please use "fixed buffer size" in FL studio as a workaround for now.

Randy thanks....AND MAKE KAIVO THEN ! :))))))))

Aalto AU version 1.6.1 not loading in Live 9.1.7 32 bit
OSX 10.9.5

@mtvic, I'm not sure why. That configuration was tested a lot, and a problem with AU not showing was fixed for 1.6.1.

If the plugin is not showing up, you can look to verify that it's in the AU Library folder: /Library/Audio/Plug-Ins/Components. If it is there, you could try removing it using the Finder, then running the installer again. You can also try this voodoo to remove your Audio Units cache:

@mtvic, Live 9.1.7 + Aalto AU 1.6.1 + OSX 10.9.5 works for me :)
sorry not much help ... might be work rescanning/reinstalling?

Oh yeah, make sure "Use Audio Units" is on, in the File / Folder Preferences page in Live, and try "Rescan" there as well.

Oh, Randy, it seems midi input for "Mod CC#" channel just not work. I tried just now, strange. And for just in case tried the same with Kaivo - all ok with this, midi input work and indicated fine there. Check please.
OS Win7 64bit \ DAW 32bit and Aalto VST 32bit (v161)

@antolyi/randy, just tried here with Mac/1.6.1 vst/Live9 (also N4) ... and works as expected.

I tried first with default MW, ok - then changed CC# to 10, and checked Mod worked on 10, Mod+1 on 11 , both seemed fine.

perhaps a Windows or host (daw) related issue? which daw? does the mod input flash?

Thetechnobear Thanks for reply, but you tried on Mac only, perhaps the prjblem just in windows\32bit version.

[q]perhaps a Windows or host (daw) related issue? which daw? does the mod input flash?[/q]

No, as i said i check also Kaivo on this issue - if problem would was in host then Kaivo also would have this issue. Daw different - studio one and ableton, reproduced in both. Mod input flash indicator not work, respectively. And as i said in Kaivo it work (flashes and modulated).

Oh damn.Just now i found something in this issue (in v161). Look as follow: "mod cc#" starts work (flashes and modulated) only if first send to aalto any "note on" command (from pianoroll for example). But before triggering by note on - mod cc# will not take any cc signal.

Installed back v1.5 now, all ok with this immediately. But need note that in 1.6.1 exactly character of indication (flashes) performed\optimized better (more clearer and brighter).
Also in v1.5 there some "afterimage" (or dont know how it will be in english), when cc indicator stay lit even after signal reception.

In general, will wait to fix for 1.6.1

hmm, interesting, I can see this behaviour too.
CCs are ignored until the first note comes in...

odd, it looked like an optimisation on Lives part.... but Kaivo doesnt have the same behaviour,
... so either the plugin is telling Live not to send until first note, or aalto is not responding to the CC or flashing the mod light.

Yep,"good" optimization. No, nonetheless i hope it's a bug.

If Kaivo is not doing this, then I hope I can fix it in Aalto for the next update.

My busy fingers always play a few notes on my keyboard before I test CCs. This is probably why I never saw this.

Randy thanks for reply. It would be really good. I do not know, in my opinion is a very important detail (because one of the most important Aalto aspects it use as a generator, without bind to the sequencer).
Also need mention that as i said in v1.5 it was work.