ForumsSoftware ← Lost/changed sequencer function?

Don't know why I didn't notice this until last night:
In Aalto 1.3.2, when the sequencer is locked to the host tempo, the sequencer resets to Step One when the host transport is stopped - rather than stopping on the current step and hanging out until resetting when the transport is started again (like in older Aalto versions - maybe this changed in 1.3?). Behavior is the same with AU/VST, within any host I've tried.
While we're at it, it would be cool if the sequencer would reset to whatever step is chosen in the "Offset" control - I feel like the older Aaltos did this (can't find my old ones to check right now).
I don't know if a 1.3.3 is planned - but if it is I would do almost anything to get the old functionality back. Just name it - need a lawn mowed or anything?

I'll re-examine this, thanks for the feedback. I've made some tweaks to the seq from user feedback, that unfortunately break other behaviors people were counting in. The sequencer is hard.

An update is definitely planned.

I don't know how you do it randy, by thank you.

I think the answer is "coffee", but yes, thanks Randy!

Coffee is a big part of it.

Hello, just want to make one more request for the sequencer to be fixed. Probably bad timing, what with the new instrument in the works, but I want to get this in there before it's too late or whatever.

I've been sticking with Aalto 1.2.6, which was the last version where the sequencer stops/resets/starts like I'm used to.

Sometimes I've been using 1.3.0, so that I can use the cool host-sync-ratio feature, and paste patches from the forum, etc.; 1.3.0 being the last version that resets the seq when the host transport restarts, and resets to the correct step.

I've tried the newest Aalto, but now there's a thing where the seq will start/restart on some step other than "1" - sometimes it will start on step 4, sometimes 5 or 9, etc.

Here's a simple patch made in 1.4.1 if anyone wants to confirm; for me the seq is starting on like step 4, resetting to step 1 on host transport stop, and then restarting on step 4 with a glitchy jump:

<Aalto pluginVersion="66561" presetName="aseqdemo141" presetDir="Aalto" scaleName="12-equal" scaleDir="" seq_host="1" seq_rate="0" seq_value0="0.508928597" seq_value2="0.620000005" seq_value4="0.794642925" seq_value7="0.74000001" seq_value10="0.6875" seq_value11="0.419999987" seq_value13="0.473214328" seq_value14="0.830357194" seq_pulse0="1" seq_pulse3="1" seq_pulse5="1" seq_pulse7="1" seq_pulse11="1" seq_pulse12="1" lfo_freq="1.00000012" env1_decay="0.119999997" env1_sustain="0" env1_release="0.50000006" env1_trig_select="2" env2_repeat="0" osc_pitch_lin_p="2184" delay_freq="109.999985" patcher_input_10="0000000000000000010000000000000" patcher_input_13="0000000000000000000100000000000" editor_x="264" editor_y="90" editor_width="912" editor_height="624" editor_num="1" editor_anim="1"/>

The behavior is happening for me with the AU and the VST, in any host. The behavior started in Aalto 1.3.1 - according to the Aalto version change log, there were at least two sequencer things that happened: "new software PLL for tighter host sync", and "fixed sequencer offset when stopped".

There is indeed a "jump" that happens in Aalto 1.3.0 when the host transport is stopped. But if you're lucky/good you can get the seq to stop on the step you want, and 1.3.0 does reset to the correct step, with the correct offset.

I'm happy with Aalto either way - but man if this were fixed I would be in heaven. I'm sending coffee, just in case.

EDIT: damn, it would take a cup of coffee just to read this post, shortened it a little

Hi t.m.,

Thanks for the very patient "bump." All the info is really helpful to pinpoint what went wrong. I will make time to give the sequencer a rework for the next update. There are not too many changes to get in, so this will be before the new instrument comes out.

Man, I really appreciate it Randy. Thanks for putting up with my complaining - I tried a couple ways around this but my solutions were clunky and not very playable.