ForumsSoftware ← Serial-Key copy and paste "bug"

Hello Randy,
we "talked" about that issue already. I recognized now that there is still the same problem with the Key for the VST-registration.

When copying the serial from the account page into a text editor window to save it, the format is changed and as a result this data cannot be used to activate a VST instrument on a computer. So you are still forced to be online for a registration. That´s not a problem in general (although I know this is annoying for the many offline studio PC users) but what will be, when Madrona Labs isn´t any more any day? What I am really not hoping for. Or maybe there is a longer server dropout or whatnot?

I would be happy if you could work that out. Thank you in advance.

Best wishes.

Hi, I guess you are on Windows? It's common for text editors to use a different character for "end of line" there, and maybe the slash characters are confusing your editor. But it should be no problem to find an editor that makes it look right. I have good luck with notepad++. If you can see it on the website, then you have all the data.

In any case, I plan to be still operating for years to come. I appreciate your concern about longevity.

Hi Randy,
yes I am using 2 PCs and no matter what I do - I tried notepad++ and Word and Windows texteditor - it is always the same. The format isn´t the same as on the user-account-page when I paste it in. I will give it a try on my macbook too. Any other Ideas?

I looked up the installation folder where the licence files are stored after installing the VSTs. When I watch them on the notepad++ editor it´s the same picture. I don´t know whether I can use these files for a re-installation and registration? The slashs seem to be fitting. But the middle part where it reads "licenced to and so on" is not placed correctly in the middle.

Nice to hear that you are so ambitioned with your projects :)

I'm reading again where you say the format is changed. Did you try registering a plugin with the saved text? Maybe there is no problem. The spacing you see when text is centered is completely a result of the presentation on the website and not of the text itself. So the apparent change to left alignment is normal.

There may also be a setting in notepad++ needed to fix the line endings under Windows. I'm sorry I can't find details for you right now, but I know I have made this work in the past.

I tried the first time I installed Aalto to use the saved text-file for registration and it didn´t work.

The next time re-installing on another PC and installing Kaivo I was online and did the copy to clipboard activation.

Finally I layed Internet into my studio for that kind of reason. But I want to be shure for the future because I admit to be a bit oldschool. I want to use things I like in the future too, maybe in 10 or more years too. I still have a lot of hardware synth I bought in the early 90th and I still use them. I am still very careful with software and it took a long time I really dived into that region ;)

You definitely have all the information you need in the file. Probably the line-endings are getting mixed up, depending on what program you use to save it. I'll try to find time to write a quick tutorial on this soon.

Thank you. That's really cool. Your service for your customers is great. Appreciated much :)

in Windows' Notepad you may want to activate Format/Word Wrap.

Open the text file containing your license. Then you highlight all the lines that include the license code, but only these lines. And all of it, including the blank area at the end. Once the code is highlighted, select Edit/Copy. This puts the code into Windows' clipboard.

When you run your VST host (DAW application), load Aalto, and click on the top right area. The license code will instantly be pasted into Aalto. You should now have a fully licensed copy.

Hi Phil and thank you for your tip. That seems to be a working method. I am not sure if it works with a stored text editor file stored earlier. I'll give it a try :)

sorry if I continue to state the obvious, but you can save a new text file anytime. Maybe your problem lies in the saving of the file?

  1. go to "My licenses" on this webpage. Click "show key" and click inside the text. Press ctrl+a to select the entire text (note that there is a blank area at the bottom).
  2. copy to clipboard with ctrl+c
  3. open Notepad and paste the content from the clipboard.
  4. save the text file. Now you should have a license text file that surely will work.

Thanks for the help Phil.

I'm having the exact same problem.
Aalto 1.8.2 x64 on Mac 10.12.6
I tried copying/pasting my key from Chrome, Safari and Even on a PC saving it to a .txt file transferring over and importing as per the previous post on this thread but each and every time it comes up with Sorry there was a problem, contact support??

Hi @spotta, I looked at your license key and it wasn't working because there was a space in your last name in your account. That used to cause issues with the system. Since we discovered that we filter them out. I fixed your account and rebuilt the license. it should work now.

Worked a treat, thanks for your help Randy.

On Mac 10.13.6 and same problem as mentioned above.

@hougaard, I'm not sure what problem you mean. Same as @spotta? The account looks OK. Please email me at support for faster response.

Hi @randy, I emailed support but I thought it will be easier here.

I'm trying to past my Aalto license I purchased today on the software demo version. I'm using macOS Ventura.

I copied the full license text given first...

It says: "click to past license key" but there's nowhere to past it once clicked but a message appears; "no license to past".

It must be something very obvious I missed.

Thanks for your help, I can' t wait to start!


Sorry, sorted. I didn't cmd At the license before cmd C... My bad! Btw great Pronsato's interview!

Glad you're up and running. Enjoy!