hardware and software for electronic music 
Fri, Nov 16, 2012, 12:00

Aalto 1.3.0 issues

In the short two days since its release, I have served approximately eighteen pounds of tasty Aalto downloads! That's over two billion electron volts, or enough salted peanuts to circle the Earth three times! Thanks for your support and all the feedback and comments.

A few issues with 1.3.0 bear mentioning.

Automation incompatibility from previous versions

If you have set up automation curves in Logic or Live with 1.2.6 or a previous version, these curves will be lost in 1.3. Unfortunately most hosts save automation parameters only as indexes. So when adding parameters as I've done there's no good way to preserve older automation data.

I recommend you finish up old work with 1.2.6 or render tracks to audio before installing 1.3. It is also possible to rename the old VST file "Aalto126", and run both versions simultaneously while you make the switch.

Host sync issues in Logic

The new host sync divisions feature may cause drifting off the clock in (surprise, surprise) Logic. I thought I had this problem solved but apparently it still comes up sometimes. I'll be looking for a workaround. Ableton Live and Numerology should be very solid.

Window resize issues

The size of the newly resizable GUI is only saved when the DAW file is saved. Simply closing the Aalto window does not save the data. Since the host only asks for this data when it pleases, it's hard to see how to change this. I'll look for a workaround. In the meantime, just save your file to save the current window positions.

Also, Live does a weird thing with the AU version where it tries to smoothly fade the window size, resulting in glitches during resize.

Live 9 beta crashes

While Live 8 is working fine, I have reports that the Live 9 beta is crashing with Aalto. I've asked Ableton for the beta and will investigate as soon as I can.

Manual stuck in the past

The manual was last updated for version 1.2.6. I'll update it to reflect the 1.3.0 changes as soon as I have time.

If you find any more issues, please start a forum thread under software, or email them to support at madronalabs.com. That email just goes to me, since I'm the only one here, but it allows me to file it in the right place more quickly, so your help is appreciated.

Sat, Nov 17, 2012, 01:07

I have Live 8.2.1 and it crashed 2/2 time when use the new update.

Sat, Nov 17, 2012, 09:33

Where can I get the aalto 1.26 version, would need it since I already installed the new update and I have a few tracks with automation.....

Sat, Nov 17, 2012, 11:03

I have Live 8.2.1 and it crashed 2/2 time when use the new update.

Strange... What OS? What did you do when it crashed?

Maybe just try reinstalling.

If it keeps up I will get you a version with some debugging code to try. Thanks.

Sat, Nov 17, 2012, 11:04

Where can I get the aalto 1.26 version, would need it since I already installed the new update and I have a few tracks with automation.....

Give me the weekend here to look at rearranging the parameters. If it has to be the way it is, I'll make the 1.2.6 version available again for download.

Sat, Nov 17, 2012, 11:29
        What OS? What did you do when it crashed?

I tried out some new patches, changed some parameters. Controlled with a MIDI controller. It worked for 10-15 mins, maybe too much parameters changed or something.

Windows 7 with Live.

Mon, Nov 19, 2012, 16:37

First: I really love Aalto, it's a great synth. And it has a lovly manual. And thanks a lot for the update.

But please never change the parameter order again, please just add new parameteres to the end of the list. It does not only break old songs, but also parameter mappings for hardware controllers. I spend a complete hour just for adjusting the map i have build for Reaper/Mackie Control.

Tue, Nov 20, 2012, 11:12

Hi Klinke.

Thanks for your very reasonable note, and sorry for the trouble. Unfortunately there's no good way to add parameters to a plugin that won't break previous versions. Hosts could save a parameter name, but instead, they all (so far as I know) save an absolute index.

If I wanted mappings not to break, my only choice was not good. I would have been forced to add some dummy parameters in place of ones I removed, and add the new parameters at the end, where they would not be found by users in the right order in menus, etc. So, I had to balance out an hour of pain now in mapping against an annoyance every single time one maps a parameter and confusion for new users in the future.

Anyhow, you may not care about such details but in any case thanks for understanding and I promise not to move Aalto's parameters again.

Thu, Nov 22, 2012, 01:41

Hi Randy - I've been having automation issues with 1.3...almost all the parameters are improperly named when automated...when I automate OSC pitch, it shows up as OSC ratio, ENV1 release becomes ENV1 attack, etc. Almost all the controls are that way, seems the names have been shifted by one or two degrees. Aside from that, it works fine. I'll use 1.2.6 until further notice. Thanks-

ps I use Podium 32bit on Win7 64bit.

Fri, Nov 23, 2012, 11:08

Hi Randy - I've been having automation issues with 1.3

Well this is covered above-- I had to change the parameter order which I realize is a pain for some people. It will break old files. If it's not working with new automation you're trying to make, maybe your host is caching the old parameters somehow.

Fri, Nov 23, 2012, 12:38

It was a problem with new automation...did a clean un/reinstall, got rid of several files, and now the parameters line up like they should. Works like a charm. I'm not sure which file(s) it was, but I got it now. Thanks Randy, you're the man!

Mon, Nov 26, 2012, 01:28

Does the quote below mean that Aalto will never have additional parameters?

"Unfortunately there's no good way to add parameters to a plugin that won't break previous versions. Hosts could save a parameter name, but instead, they all (so far as I know) save an absolute index. (...) I promise not to move Aalto's parameters again."

Mon, Nov 26, 2012, 09:05

I could add some at the end if it were needed. Why do you ask?

Mon, Nov 26, 2012, 15:42

Ah, OK. I thought it meant adding any parameter would break the order of existing ones. I asked because I didn't want Aalto to be "finished" feature-wise. (for example another type of filter: filter type switch parameter and possible additional filter tone control parameters)

Tue, Nov 27, 2012, 23:57

I love the update but unfortunately when routing modulation I occasionally get insane cpu usage spikes in ableton 8 (windows 7)(last spike was 1400% cpu) as well as multiple crashes when routing modulation or when exiting from ableton having it shut down with an error. The most consistent source of the error is when I self modulate the lfo level with the lfo and then route the lfo to another parameter, this consistently causes a spike in cpu and often a crash.

I have tried reinstalling with no luck.

Wed, Nov 28, 2012, 09:55

Hmm, haven't heard of any other modulation problems. I did find one bug that could in rare cases cause crashes in other areas. This will come out with 1.3.1 very soon and hopefully fix your problem. Please keep me posted.